EIGRP over GRE over PPP over T1

Why? Why the hell not! This pointless exercise makes a Cisco 2621XM talk to a Cisco 1760 using EIGRP over a GRE tunnel with a Cisco 7204VXR in the middle. The 2621XM has a pair of WIC-1DSU-T1-V2 cards in PPP multilink to the 7204VXR with a PA-4T1 card, then going to the 1760’s single WIC-1DSU-T1-V2 card. For the sake of simplicity I won’t bother using IPsec over GRE though you should be doing this if your tunnel crosses outside networks.

Let’s bring up the glorious T1 network.

Starting with the 7204VXR we need to create the channel group on the T1 controllers.

controller T1 4/0
  channel-group 0 timeslots 1-24
controller T1 4/1
  channel-group 0 timeslots 1-24
controller T1 4/2
  channel-group 0 timeslots 1-24

Doing this will create the serial interfaces Serial4/0:0, Serial4/1:0 and Serial4/2:0. Since slots 4/0 and 4/1 both run to the 2621XM, we’ll need to create the PPP multilink interface prior to configuring the serial interfaces.

interface Multilink1
  description T1BOND-TO-C2621XM
  ip address 10.60.100.1 255.255.255.248
  ppp multilink
  ppp multilink group 1
  ppp multilink fragment disable

Now we’ll configure all three serial interfaces on the 7204VXR. The third serial interface will not be part of a PPP multilink group as the endpoint 1760 only uses one T1 module.

interface Serial4/0:0
  no ip address
  encapsulation ppp
  ppp multilink
  ppp multilink group 1
interface Serial4/1:0
  no ip address
  encapsulation ppp
  ppp multilink
  ppp multilink group 1
interface Serial4/2:0
  description T1-TO-C1760
  ip address 10.60.110.1 255.255.255.248
  encapsulation ppp

Yay! Next up is the 2621XM. Here we’ll create the PPP multilink interface and add the serial interfaces to it.

interface Multilink1
  description T1BOND-TO-C7204VXR
  ip address 10.60.100.2 255.255.255.248
  ppp multilink
  ppp multilink fragment disable
  ppp multilink group 1
interface Serial0/0
  no ip address
  encapsulation ppp
  tx-ring-limit 26
  tx-queue-limit 26
  no keepalive
  no fair-queue
  service-module t1 cablelength short 110ft
  ppp multilink
  ppp multilink group 1
interface Serial0/1
  no ip address
  encapsulation ppp
  tx-ring-limit 26
  tx-queue-limit 26
  no keepalive
  no fair-queue
  service-module t1 cablelength short 110ft
  ppp multilink
  ppp multilink group 1

Next up is configuring the serial interface on the 1760.

interface Serial0/0
  description T1-TO-C7204VXR
  ip address 10.60.110.2 255.255.255.248
  encapsulation ppp
  tx-ring-limit 26
  tx-queue-limit 26
  no keepalive
  no fair-queue
  service-module t1 cablelength short 110ft

OK! Before we can make the GRE tunnel work, we gotta drop in a couple static routes on the 2621XM and 1760 so they can talk to eachother. In the real world you’d probably be using BGP or a default route upstream.

2621XM: ip route 10.60.110.0 255.255.255.248 Multilink1
1760: ip route 10.60.100.0 255.255.255.248 Serial0/0

GRE tunnel time!

Let’s start with the 2621XM.

interface Tunnel0
  ip address 192.168.40.1 255.255.255.248
  tunnel source Multilink1
  tunnel destination 10.60.110.2

Now the 1760 side.

interface Tunnel0
  ip address 192.168.40.2 255.255.255.248
  tunnel source Serial0/0
  tunnel destination 10.60.100.2

Make EIGRP do things.

For this lab I’ve attached 172.16.20.1/24 to Lo0 on the 2621XM and 172.16.21.1/24 to Lo0 on the 1760.

2621XM:

router eigrp 1
  passive-interface default
  no passive-interface Tunnel0
  network 172.16.20.0 0.0.0.255
  network 192.168.40.0 0.0.0.7
  no auto-summary

1760:

router eigrp 1
  passive-interface default
  no passive-interface Tunnel0
  network 172.16.21.0 0.0.0.255
  network 192.168.40.0 0.0.0.7
  no auto-summary

But does it work?

c2621xm#sh ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.40.2 Tu0 14 00:34:31 7 5000 0 3
c2621xm#sh ip route eigrp
D 172.16.21.0 [90/297372416] via 192.168.40.2, 00:35:03, Tunnel0
c2621xm#ping 172.16.21.1
Sending 5, 100-byte ICMP Echos to 172.16.21.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms
Facebooktwitterredditpinterestlinkedinmail

You may also like...

1 Response

  1. January 3, 2016

    […] not as exciting as my EIGRP over GRE over PPP over T1 article, today we’ll setup a DS3 connection between a Cisco 7204VXR and Cisco 2621XM with a […]

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.