Fun With Basic ATM And OSPF On Cisco

While not as exciting as my EIGRP over GRE over PPP over T1 article, today we’ll setup a DS3 connection between a Cisco 7204VXR and Cisco 2621XM with a little OSPF mixed in. The 7204VXR has the PA-A3-T3 “ATM WAN DS3 Port Adaptor” and the 2621XM has the NM-ATM-DS3 “ATM DS3” module.

First we’ll bring up the ATM interface on the 7204VXR. The only thing we’re adding to ATM3/0 is enabling scrambling because it sounds cool. Our actual IP config is done by creating ATM3/0.1 as point-to-point.

interface ATM3/0
  no ip address
  no ip route-cache
  atm scrambling cell-payload
  no atm ilmi-keepalive
  no atm enable-ilmi-trap
interface ATM3/0.1 point-to-point
  ip address 10.60.254.1 255.255.255.252
  no ip route-cache
  no atm enable-ilmi-trap
  cdp enable
  pvc 0/40
    oam-pvc manage
    encapsulation aal5snap

Now we’ll bring up the 2621XM side.

interface ATM1/0
  no ip address
  atm scrambling cell-payload
  no atm ilmi-keepalive
interface ATM1/0.1 point-to-point
  ip address 10.60.254.2 255.255.255.252
  cdp enable
  pvc 0/40
    oam-pvc manage
    encapsulation aal5snap

Did it work?

c7204vxr#sh cdp nei atm3/0.1
Device ID Local Intrfce Holdtme Capability Platform Port ID
c2621xm ATM3/0.1 158 R S I 2621XM ATM1/0.1

OK. Time for some OSPF or whatever. On the 7204VXR I’ve put 10.44.44.1/24 in Lo1 for area 5, and on the 2621XM I’ve put 10.44.45.1/24 in Lo1 for area 10.

7204VXR:

router ospf 1
  router-id 10.60.254.1
  passive-interface default
  no passive-interface ATM3/0.1
  network 10.44.44.0 0.0.0.255 area 5
  network 10.60.254.0 0.0.0.3 area 0

2621XM:

router ospf 1
  router-id 10.60.254.2
  passive-interface default
  no passive-interface ATM1/0.1
  network 10.44.45.0 0.0.0.255 area 10
  network 10.60.254.0 0.0.0.3 area 0

Did it work?

c7204vxr#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
10.60.254.2 0 FULL/ - 00:00:36 10.60.254.2 ATM3/0.1
c7204vxr#sh ip route ospf
O IA 10.44.45.1/32 [110/3] via 10.60.254.2, 00:44:54, ATM3/0.1

I guess so.

Facebooktwittergoogle_plusredditpinterestlinkedinmail

You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *